Sunday, July 6, 2008

Extending an Airport Extreme Base Station Network with a WRT54G

A few weeks ago, I purchased 7" iMate digital picture frame off of woot for about $75. I got it connected to a shared photo library on Windows Media Player 11 on my Windows XP Pro SP3 box. However, the downside was that it didn't connect to my Airport Extreme Base Station in N/G compatibility mode. The only way to get it to work was in 802.11b mode. (This can be done by holding down the 'option' key before selecting the 'modes' combo in the Airport Utility).

This annoyed me fiercely because my MacBook Pro then had very slow network access to my Time Machine backup drive on my AEBS. So, I purchased a Linksys WRT54G because I assumed iMate would have ensured they could connect to one of the most popular home wifi hubs. Luckily, I assumed correctly. However, now I had a problem: how do I hook up my Airport Extreme Base Station and my Linksys WRT54G so that all computers connected to them could see each other? This meant that I could not run the WRT54G as a NAT like I had always done in the past. Instead, I needed to use it as an ethernet bridge.

I did a lot of googling last night, and most people are daisy-chaining their WRT54G with one as a wifi client so it could extend their existing network. This is not what I wanted to do. I want separate 802.11N and 802.11B/G segments for maximum speed for my MacBook Pro.

I tried and failed to get the WRT54G to work as a router using the advnaced routing tab. Then, I found suggestions to simply attach the AEBS to the WRT54G's LAN port instead of its WAN port, and then disable DHCP in the WRT54G. This worked like a charm! Now, all my devices can see each other, and I have two separate wireless segments. My MacBook Pro's network is now screaming fast.

The downside is that I can't seem to access the WRT54G's admin page unless its connected to the AEBS through its WAN port. This is really annoying, and I hope someone can tell me how best to fix it.

2 comments:

B said...

thank you, This 2+ yr old post is still the only thing I found to remedy the same situation. My AEBS is new this month, and still has the same slow WiFi issues.

To be sure that I am clear, what settings are changed on the WRT54G besides the "DHCP Server" being turned off? (mine is a version 2) Do I need to also change the DHCP to something else at the top of the setup page (possibly ppoe?) and should the WRT54G firewall be turned off? Thanks again, barry

Heath said...

I honestly don't remember. As I said in the blog post, it is annoying to get to the configuration page, and thankfully, I haven't had to touch this configuration since posting. I wish I'd linked to the original post that had the suggestion to disable dhcp. I also wish I knew more about wy this worked.

If I ever go into the configuration page, I'll post the configuration here.